“HTML5 Browser with WebGL support required!”

Have you seen this error message before? It's a rare error message due to new technology on older browsers and / or hardware.

For your browser to be compatible with any immersive visuals (360°/3D), it requires you to update your browser to support technology called WebGL. This is used for rendering all interactive 3D and 2D graphics. WebGL is supported by all modern browsers: Google Chrome, Mozilla Firefox, Apple Safari, Microsoft Edge, etc.

If you get this error message when using TrueTour™, or any immersive visuals, you can assume one of the following:

  1. Your browser needs to be updated
  2. WebGL and hardware acceleration were disabled in your browser
  3. A browser plug-in disabled your WebGL
  4. Your computer’s hardware does not support WebGL

Here’s a list of browsers that support WebGL. If you don’t see your browser listed, please update your browser to one on this list:

https://caniuse.com/#feat=webgl

Still not working? Check if your hardware is WebGL-compatible

WebGL uses the graphics card in your computer to do all calculations, so it will not interfere with your main CPU to slow down your computer. If your computer does not have a graphics card, it will be hard to overcome the WebGL error message and still have a good experience with TrueTour. You can either add a graphics card to the computer, or upgrade the computer itself, to be ready for all new technologies that will soon become the status quo.

Click Here to Enable WebGL on Internet Explorer

Click Here to Enable WebGL on Google Chrome

Did this answer your question?